ФорумПрограммированиеPythonБатарейки → pip-tools - requirements.txt helper

pip-tools - requirements.txt helper

  • phpdude

    Сообщения: 26618 Репутация: N Группа: в ухо

    Spritz 18 ноября 2015 г. 11:58

    nvie/pip-tools [github.com]

    достаточно полезная батарейка - умеет компилить готовый requirements.txt с версиями текущими в репо для всех подзависимостей и тп - фактически тоже самое что и

    virtualenv test && . test/bin/activate && pip install -r requirements.in && pip freeze > requirements.txt

    Спустя 16 сек.

    только конечно ничего не устанавливая в реальности, только version & dependency resolving

    Сапожник без сапог
  • Sinkler

    Сообщения: 9658 Репутация: N Группа: в ухо

    Spritz 3 декабря 2015 г. 7:47, спустя 14 дней 19 часов 49 минут

    удобно, заюзал

  • Sinkler

    Сообщения: 9658 Репутация: N Группа: в ухо

    Spritz 11 апреля 2017 г. 18:34, спустя 495 дней 9 часов 46 минут

    @phpdude вот ещё подобная прикольная штука

    naiquevin/pipdeptree [github.com]

    киллер-фича - узнать какой пакет мешает обновлению

    например хотим узнать что мешает обновить django:

    
    [email protected]:/app# pipdeptree --reverse --packages django
    Django==1.10.7
      - django-allauth==0.31.0 [requires: Django>=1.8]
      - django-cacheback==1.3.1 [requires: django<2.0,>=1.8]
      - django-classy-tags==0.8.0 [requires: Django>1.3]
        - django-haystackbrowser==0.6.2 [requires: django-classy-tags>=0.3.4.1]
      - django-clear-cache==0.3 [requires: Django>=1.0]
      - django-debug-toolbar==1.7 [requires: Django>=1.8]
        - django-haystack-panel==0.2.1 [requires: django-debug-toolbar>=1.0]
      - django-haystack==2.5.2.dev38+gd761d12 [requires: Django>=1.8]
        - django-haystackbrowser==0.6.2 [requires: django-haystack>=1.2.0]
        - drf-haystack==1.6.1 [requires: django-haystack>=2.5.0]
      - django-haystack==2.5.2.dev38+gd761d12 [requires: Django<1.11]
        - django-haystackbrowser==0.6.2 [requires: django-haystack>=1.2.0]
        - drf-haystack==1.6.1 [requires: django-haystack>=2.5.0]
      - django-rest-auth==0.9.1 [requires: Django>=1.8.0]
      - drf-haystack==1.6.1 [requires: Django<1.11,>=1.8]
      - drf-nested-routers==0.90.0 [requires: Django>=1.8]
    

    видим у каких пакетов в зависимостях Django<1.11

  • Crank

    Сообщения: 541 Репутация: N Группа: Джедаи

    Spritz 12 апреля 2017 г. 1:53, спустя 7 часов 18 минут 39 секунд

    Сохраним

Пожалуйста, авторизуйтесь, чтобы написать комментарий!