ФорумРазработкаУстановка и администрирование ПОВебсервер → Apache + fcgid/fastcgi + PHP 5.2 + PHP 5.3 + suexec

Apache + fcgid/fastcgi + PHP 5.2 + PHP 5.3 + suexec

  • Абырвалг

    Сообщения: 6476 Репутация: N Группа: Джедаи

    Spritz 6 июля 2011 г. 4:29

    Дайте кто-нибудь статью, по которой вы реально настраивали весь этот зоопарк и он заработал.

    Что именно использовали: mod_fcgid или mod_fastcgi?
    Как апач работал - mpm-worker или prefork или еще какая поебень?

    А то у меня все что-то не получается настроить, то не может форкнуть что-то там, то памяти не хватает, то еще неизвестно что.
  • phpdude

    Сообщения: 26624 Репутация: N Группа: в ухо

    Spritz 6 июля 2011 г. 9:43, спустя 5 часов 13 минут 58 секунд

    Что именно использовали: mod_fcgid или mod_fastcgi?
    Как апач работал - mpm-worker или prefork или еще какая поебень?

    на префорки или воркеры - похуй, работает с обоими, рекомендую воркер. тредовая модель - не форкается 100500 раз, жрет меньше ресурсов, быстрее отклик.

    а про mod_fastcgi vs mod_fcgid - тут все просто, mod_fastcgi (я читал) работает типа быстрее, но только на apache 1.3. mod_fcgid работает на всех(ну или 2.хх) ветках апача. самое смешное - что вроде как и ставится и запускаются оба, но именно суексек не работает :-)

    сам проебал пару ночей, выбирай тру решение и будет айфово =)
    Сапожник без сапог
  • Абырвалг

    Сообщения: 6476 Репутация: N Группа: Джедаи

    Spritz 6 июля 2011 г. 9:47, спустя 3 минуты 35 секунд

    спасибо. Один раз уже пытался перенастроить - не получилось, восстановил все взад.

    Че самое интересное - и правда ночей. Так как днем и времени нет да и нужно что б сайты работали
    Спустя 32 сек.
    весь сыр-бор из-за APC. Все и сейчас работает, кроме APC - между запросами ниче не сохраняется
  • phpdude

    Сообщения: 26624 Репутация: N Группа: в ухо

    Spritz 6 июля 2011 г. 9:49, спустя 2 минуты 20 секунд

    http://forum.lissyara.su/viewtopic.php?f=8&t=20403

    вот даже тему на лисяре я создавал в свое время
    Спустя 55 сек.
    фастсги то сам модуль работает, но суексек несовместим (с апишками апача видимо) и блядь получается что один fastcgi - для апача 1.3, а fcgid - для апача 2.хх. ебанутся кароче :-)
    Сапожник без сапог

Пожалуйста, авторизуйтесь, чтобы написать комментарий!