z100

Мужчина
Статус
  • Активный

Последние сообщения z100

  • Базы данныхне могу заставить работать php с mysql • 10 мая 2014 г. 9:35

    Есть linux lfs версии 7.0 Из исходников установлены СУБД mysql версииmysqld Ver 5.5.17-log for Linux on i686 (Source distribution),веб-сервер apache версииhttpd -vServer version: Apache/2.4.9 (Unix)Server built: Apr 8 2014 19:04:23и php версииphp -vPHP 5.5.11 (cli) (built: Apr 23 2014 23:04:2...
    Есть linux lfs версии 7.0 Из исходников установлены СУБД mysql версии
    mysqld Ver 5.5.17-log for Linux on i686 (Source distribution),
    веб-сервер apache версии
    httpd -v
    Server version: Apache/2.4.9 (Unix)
    Server built: Apr 8 2014 19:04:23
    и php версии
    php -v
    PHP 5.5.11 (cli) (built: Apr 23 2014 23:04:28)
    Copyright © 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright © 1998-2014 Zend Technologies
    СУБД работает отлично, завёл пользователя, базу, из mysql клиента подсоединяюсь под этим пользователем и захожу в базу, всё работает нормально.
    Веб-сервер работает то же отлично.
    Сам модуль php для apach-а работает то же нормально. Создал страничку - <?php echo phpinfo(); ?>
    и вот что она выдала по поводу mysql:
    MySQL driver for PDO George Schlossnagle, Wez Furlong, Ilia Alshanetsky, Johannes Schlueter
    MySQL Zeev Suraski, Zak Greant, Georg Richter, Andrey Hristov
    MySQLi Zak Greant, Georg Richter, Andrey Hristov, Ulf Wendel
    MySQLnd Andrey Hristov, Ulf Wendel, Georg Richter, Johannes Schlüter

    при этом по команде php -m модуля для работы с mysql вроде как нет:
    php -m

    bcmath
    bz2
    calendar
    Core
    ctype
    date
    dba
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    hash
    iconv
    json
    libxml
    mbstring
    pcre
    PDO
    pdo_sqlite
    Phar
    posix
    Reflection
    session
    SimpleXML
    sockets
    SPL
    sqlite3
    standard
    tokenizer
    xml
    xmlreader
    xmlwriter
    zlib

    [Zend Modules]

    Папки в /usr/lob/php с модулями вообще нет.

    Конфигурировал php вот с такими опциями:

    ./configure –prefix=/usr \
    –sysconfdir=/etc \
    –localstatedir=/var \
    –with-apxs2=/usr/bin/apxs \
    –datadir=/usr/share/php \
    –mandir=/usr/share/man \
    –enable-dba \
    –enable-fpm \
    –with-fpm-user=apache \
    –with-fpm-group=apache \
    –with-config-file-path=/etc \
    –with-zlib \
    –enable-bcmath \
    –with-bz2 \
    –enable-calendar \
    –enable-exif \
    –enable-ftp \
    –with-openssl-dir=/usr \
    –with-gd=/usr \
    –with-jpeg-dir=/usr \
    –with-png-dir=/usr \
    –with-zlib-dir=/usr \
    –with-freetype-dir=/usr \
    –with-mysql-sock=/var/run/mysql \
    –enable-sockets \
    –enable-mbstring

    Всё бы было ничего но вот пытаюсь открыть такую страничку:

    <?php


    // Данные для mysql сервера
    $dbhost = "localhost"; // Хост
    $dbuser = "user"; // Имя пользователя
    $dbpassword = "pas"; // Пароль
    $dbname = "baza"; // Имя базы данных

    // Подключаемся к mysql серверу
    $link = mysql_connect($dbhost, $dbuser, $dbpassword);

    // Выбираем нашу базу данных
    mysql_select_db($dbname, $link);

    // Создаём таблицу customer
    // т.е. делаем sql запрос
    $query = "create table customer (id int(2) primary key auto_increment, name varchar(100), tel varchar(20))";
    mysql_query($query, $link);

    // Закрываем соединение
    mysql_close($link);


    ?>

    и выдаёт мне: Удаленный сервер или файл не найден хотя просто html страницы или страничку вида: <?php echo phpinfo(); ?> открывает отлично.

    Смотрю в логи mysql а там вообще нет признака что бы под пользователем заходили, вообще конекта нет. Хотя из mysql клиента захожу нормально.

    Вопрос у меня php собран без поддержки mysql?

    И ещё один вопрос.

    Запускал СУБД mysql и apache в chroot с скинутыми в этот chroot библиотеками и модулем php, так же с библиотеками. Всё работает отлично, правда работу php с mysql не проверял. Судя по работе не в chroot работать не будет, но второй вопрос не в этом. Подскажите пожалуйста при такой работе в chroot php будет работать с библиотеками расположенными в chroot или будет использовать системные библиотеки? Если системные то как заставить php не вылазить из chroot и использовать библиотеки скинутые в chroot?

    За помощь заранее благодарен!
  • PHP для идиотовкак скомпилить php без gd • 13 апреля 2014 г. 10:43

    В скрипте configure есть опция with-gd которая указывает на путь к паке где установлен этот gd но нет опции для того что бы откомпилить php без gd, опции –disable-gd нет, или я ошибаюсь????????
    В скрипте configure есть опция with-gd которая указывает на путь к паке где установлен этот gd но нет опции для того что бы откомпилить php без gd, опции –disable-gd нет, или я ошибаюсь????????
  • PHP для идиотовошибка при компилировании php-5.5.11 • 11 апреля 2014 г. 16:08

    Пытаюсь поставить из исходников php-5.5.11.tar.bz2Линукс lfs версии 7.0 но некоторые пакеты обновлены до последних версий.Опции такие:sed -i -e 's/2.6.5 2.7/& 3.0/' configure && \./configure –prefix=/usr \ –sysconfdir=/etc \ ...
    Пытаюсь поставить из исходников php-5.5.11.tar.bz2
    Линукс lfs версии 7.0 но некоторые пакеты обновлены до последних версий.
    Опции такие:

    sed -i -e 's/2.6.5 2.7/& 3.0/' configure && \
    ./configure –prefix=/usr \
    –sysconfdir=/etc \
    –localstatedir=/var \
    –with-apxs2=/usr/bin/apxs \
    –datadir=/usr/share/php \
    –mandir=/usr/share/man \
    –enable-dba \
    –enable-fpm \
    –with-fpm-user=apache \
    –with-fpm-group=apache \
    –with-config-file-path=/etc \
    –with-zlib \
    –enable-bcmath \
    –with-bz2 \
    –enable-calendar \
    –enable-exif \
    –enable-ftp \
    –with-openssl-dir=/usr \
    –with-gd=/usr \
    –with-jpeg-dir=/usr \
    –with-png-dir=/usr \
    –with-zlib-dir=/usr \
    –with-freetype-dir=/usr \
    –with-mysql-sock=/var/run/mysql \
    –enable-sockets \
    –enable-mbstring \
    –enable-mbstring

    Конфигурирование прошло нормально
    Компилирую командой:
    make без опций, выдаёт такую ошибку:

    /prog/php-5.5.11/ext/gd/gd.c:57:22: фатальная ошибка: X11/xpm.h: Нет такого файла или каталога
    компиляция прервана.
    make: *** [ext/gd/gd.lo] Ошибка 1

    Что это за gd не знаю, но:
    gd установлен: libgd-2.1.0.tar иксов нет, что за файл xpm.h и из какого пакета он не знаю.
    Мне всего то нужно установить модуль для apach-а, мне не нужен интерпретатор php.
    Вот вывод configure:
    http://pastebin.com/ePDNsh19
    Вот вывод make:
    http://pastebin.com/Z7bGcSLE
    Как установить только модуль и как победить эту ошибку, если кто знает помогите пожалуйста!!!!!