ФорумПрограммированиеPHP для идиотов → Sphinx

Sphinx

  • ebuilder

    Сообщения: 7 Репутация: N Группа: Кто попало

    Spritz 28 декабря 2011 г. 4:52, спустя 1 час 4 минуты 25 секунд

    yum install mysql mysql-server mysql++-devel


    выдало Error: Missing Dependency: mysql = 5.0.45-4.fc8 is needed by package mysql-devel
  • Ivan

    Сообщения: 1316 Репутация: N Группа: Адекваты

    Spritz 28 декабря 2011 г. 10:13, спустя 5 часов 20 минут 18 секунд


    libmysql-dev



    http://packages.debian.org/en/lenny/libmysql++-dev - это вот она?


    Причем тут дебиан, если у тебя федора, и да - если какого-то пакета нету надо уметь собирать его руками. И пакет называется libmysql-dev, без ++
    Спустя 23 сек.
    needed by package mysql-devel

    А mysql-devel пробовал запросить юмом?
  • ebuilder

    Сообщения: 7 Репутация: N Группа: Кто попало

    Spritz 28 декабря 2011 г. 13:20, спустя 3 часа 6 минут 50 секунд

    Ivan, скажи, мот вот это оно:
    http://rpm.pbone.net/index.php3/stat/3/limit/1/srodzaj/1/dl/40/search/mysql-devel/field[]/1/field[]/2 - ?



    А mysql-devel пробовал запросить юмом?


    yum install mysql-devel
    fedora 100% |=========================| 2.1 kB 00:00
    updates 100% |=========================| 2.6 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    –> Running transaction check
    —> Package mysql-devel.i386 0:5.0.45-4.fc8 set to be updated
    –> Processing Dependency: mysql = 5.0.45-4.fc8 for package: mysql-devel
    –> Processing Dependency: openssl-devel for package: mysql-devel
    –> Running transaction check
    —> Package mysql-devel.i386 0:5.0.45-4.fc8 set to be updated
    –> Processing Dependency: mysql = 5.0.45-4.fc8 for package: mysql-devel
    —> Package openssl-devel.i386 0:0.9.8b-17.fc8 set to be updated
    –> Processing Dependency: krb5-devel for package: openssl-devel
    –> Running transaction check
    —> Package mysql-devel.i386 0:5.0.45-4.fc8 set to be updated
    –> Processing Dependency: mysql = 5.0.45-4.fc8 for package: mysql-devel
    —> Package krb5-devel.i386 0:1.6.2-9.fc8 set to be updated
    –> Processing Dependency: libselinux-devel for package: krb5-devel
    –> Processing Dependency: e2fsprogs-devel for package: krb5-devel
    –> Processing Dependency: keyutils-libs-devel for package: krb5-devel
    –> Running transaction check
    —> Package keyutils-libs-devel.i386 0:1.2-2.fc6 set to be updated
    —> Package e2fsprogs-devel.i386 0:1.40.2-10.fc8 set to be updated
    —> Package mysql-devel.i386 0:5.0.45-4.fc8 set to be updated
    –> Processing Dependency: mysql = 5.0.45-4.fc8 for package: mysql-devel
    —> Package libselinux-devel.i386 0:2.0.37-1.fc8 set to be updated
    –> Processing Dependency: libsepol-devel >= 2.0.10-1 for package: libselinux-devel
    –> Running transaction check
    —> Package mysql-devel.i386 0:5.0.45-4.fc8 set to be updated
    –> Processing Dependency: mysql = 5.0.45-4.fc8 for package: mysql-devel
    —> Package libsepol-devel.i386 0:2.0.11-1.fc8 set to be updated
    –> Finished Dependency Resolution
    Error: Missing Dependency: mysql = 5.0.45-4.fc8 is needed by package mysql-devel


    ….и да - если какого-то пакета нету надо уметь собирать его руками…


    Вообщем я не догоняю совсем, что значит собрать? Сколько может стоить консультация по сборке? :)
  • Ivan

    Сообщения: 1316 Репутация: N Группа: Адекваты

    Spritz 28 декабря 2011 г. 14:55, спустя 1 час 35 минут

    распаковал тар.гз, перешел в директорию (cd blablabla)
    и оттуда команды, поочередно:
    ./configure
    make
    make install
    Спустя 39 сек.
    Error: Missing Dependency: mysql

    так у тебя mysql не установлено по ходу
  • ebuilder

    Сообщения: 7 Репутация: N Группа: Кто попало

    Spritz 29 декабря 2011 г. 5:36, спустя 14 часов 41 минуту 24 секунды

    так у тебя mysql не установлено по ходу


    Установлен, сайты то работают)

    Ivan, скажи плз: http://rpm.pbone.net/index.php3/stat/3/limit/1/srodzaj/1/dl/40/search/mysql-devel/field[]/1/field[]/2 - вот это и есть libmysql-dev ??
  • Ivan

    Сообщения: 1316 Репутация: N Группа: Адекваты

    Spritz 29 декабря 2011 г. 7:31, спустя 1 час 54 минуты 59 секунд

    не ебу, обнови mysql - он говорит у тебя версия старая

Пожалуйста, авторизуйтесь, чтобы написать комментарий!