ФорумСообществоФлейм → мавр спалилсо

мавр спалилсо

  • phpdude

    Сообщения: 26624 Репутация: N Группа: в ухо

    Spritz 18 апреля 2009 г. 16:05

    // допустим, в модуле формы документа есть процедура "Печать()", которую надо вызвать из внешней обработки..
    // тогда пишем во внешней обработке:
    Перем тКонт; // это - переменная модуля!
    //…
    Процедура РаспечататьДокументПроцедуройМодуляЕвоннойФормы(тДокум)
    ОткрытьФорму(тДокум,тКонт);
    тКонт.Форма.ОбработкаОжидания("Печать",1);
    Форма.ОбработкаОжидания("МаврЗделалСвайоДело",1);
    КонецПроцедуры
    Процедура МаврЗделалСвайоДело()
    Если ТипЗначенияСтр(тКонт)="ГрупповойКонтекст" Тогда тКонт.Форма.ОбработкаОжидания("") КонецЕсли;
    Форма.ОбработкаОжидания("");
    КонецПроцедуры
    //..
    // в самом конце модуля, после конца последней процедуры/функции:
    тКонт=0;
    //
    // тока оно мелькать будит… ничо?.. )))))
    Сапожник без сапог
  • Givi

    Сообщения: 2284 Репутация: N Группа: Адекваты

    Spritz 19 апреля 2009 г. 4:50, спустя 12 часов 45 минут 23 секунды

    phpdude, Процедура МаврЗделалСвайоДело() - он ешо и неграмотный пиздецки.
  • mario

    Сообщения: 6067 Репутация: N Группа: Джедаи

    Spritz 19 апреля 2009 г. 8:52, спустя 4 часа 1 минуту 53 секунды

    тут даже не чего сказать :DDD
  • Mustafa

    Сообщения: 22 Репутация: N Группа: Кто попало

    Spritz 18 августа 2012 г. 8:48, спустя 1216 дней 23 часа 55 минут

    Давай поговорим потом а сейчас я пойду спать.

Пожалуйста, авторизуйтесь, чтобы написать комментарий!